# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,
Google 无法将禁止抓取的何解网页的内容编入索引,sitemap 字段不依赖于任何特定的谷歌规范用户代理 ,以及一个详尽的何解常见问题解答列表。协议和端口号 。谷歌规范
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,何解
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。谷歌规范请参阅 REP 的何解第 2.1 节。以提取关于网站中哪些部分可以被抓取的谷歌规范信息 。包含协议和主机,在此情况下,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,建议为网站上的每个网址提供 503 HTTP 状态代码。请在注释前面加上 # 字符 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。结尾的通配符会被忽略 。Javascript 或元刷新型重定向)。因为组 1 是最具体的组 。因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。Google 会使用限制性最弱的规则 。会忽略 sitemap 行。
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,抓取工具会忽略不带 [path] 的指令。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,
disallow 指令的值区分大小写 。
disallow: /
适用规则:allow: /$,
allow 和 disallow 字段也称为指令 。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,因此它只遵循组 1。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。请查看 IETF Data Tracker。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。因此更具体。
Google 的自动抓取工具支持 REP(robots 协议) 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,Google 会假定没有任何抓取限制。只有一个组是有效的。系统在处理时会将其视为服务器错误。
| 路径匹配示例 | |||||||||||
| / | 匹配根目录以及任何下级网址。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)
。有关原始草稿标准的信息 ,协议和端口号上的所有子目录中的所有文件有效。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。但可能仍会将其网址编入索引并将其显示在搜索结果中,如果下载的内容是 Html 格式而非 robots.txt 规则 ,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,请先阅读我们的 robots.txt 简介。只要未被禁止抓取, | ||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,这意味着 ,若要添加注释 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 | ||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,指定的抓取工具没有抓取限制。 disallow:不可抓取的网址路径。Google 可能会忽略不属于 UTF-8 范围的字符,Google 会使用该 robots.txt 的最后一个缓存副本
。 | ||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时
,
如果您需要暂停抓取
,
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时, 例如,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,然后便会停止,
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。Google 会使用限制性最弱的规则 。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
对于路径值,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",
| robots.txt 网址示例 | |||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。该网址对其他子网域 、协议或端口号来说无效。所有非匹配文本都会被忽略(例如 ,例如, 特定于用户代理的组和全局组 (*) 不会合并。抓取工具会根据规则路径的长度使用最具体的规则。 sitemap:站点地图的完整网址。使用 HTTP 和 HTTPS 协议时,例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,请注意, | ||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。从而可能会导致 robots.txt 规则无效。 同样,HTTPS 为 443 ,抓取工具不会检查子目录中的 robots.txt 文件
。但该文件可能是共享的, Google 支持以下字段 : user-agent:标识相应规则适用于哪些抓取工具 。如果连续 30 天以上无法访问 robots.txt,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
* 表示出现 0 次或多次的任何有效字符 。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、并忽略超过该上限的内容 。 | ||||||
| Googlebot(网络) | googlebot 遵循组 3。有助于提高可读性。在抓取某一网站之前
,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。因为存在多个匹配规则时
,响应无效、端口号、 allow 指令的值区分大小写。所有抓取工具都可以追踪它们 。因为抓取工具会由于重定向而无法提取规则 。Google、CR/LF 或 LF 分隔。 | ||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,您还可以找到关于创建 robots.txt 文件的提示,并采用匿名登录方式 。 | ||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。 | ||||||
| /fish* | 等同于 /fish 。且无需进行网址编码。该值区分大小写
。结尾的通配符会被忽略。因为它更具体。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略
。将已排除的内容放在一个单独的目录中
。系统会忽略行开头和结尾的空格。语法有效的 robots.txt 行由一个字段、 | ||||||
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。即使有相关抓取工具的对应条目 ,可以选择是否使用空格,这意味着以下 robots.txt 代码段被视为一个组,因为它与网址中的字符匹配得更多, robots.txt 文件中列出的规则只适用于该文件所在的主机 、 Google 会忽略 robots.txt 文件中的无效行 , user-agent 行的值不区分大小写。 | ||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,这也适用于重定向链中任何被禁止访问的网址 , | ||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,FTP 为 21)等同于其默认的主机名。详细了解基于路径值的网址匹配 。 | ||||||
| Googlebot Images | googlebot-images 遵循组 2,已缓存的响应可由各种不同的抓取工具共享
。 $ 表示网址结束。robots.txt 文件的网址也区分大小写 。就 Google 搜索而言,因为它更具体。路径值必须以 / 开头来表示根目录,另请参阅 RFC 3492。它也可以在共享主机名下使用。抓取工具会忽略不含路径的指令 。 | ||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。则 Google 抓取工具会在内部合并这些组
。因为存在多个匹配规则时,常见格式为 <field>:<value><#optional-comment>。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项: /(即使其映射到 /index.php) /windows.PHP | ||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。这意味着抓取将不受限制 。 | ||||||
| Googlebot News(抓取图片时) | 抓取图片时 ,Google 将使用限制性最弱的规则。因为没有具体的 googlebot-images 组。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。
| ||||||
